Go Back   Ford Expedition Forum > Ford Expedition Forum > 2nd Gen - 2003 - 2006

Sponsored Ads
Register to remove these ads.


2nd Gen - 2003 - 2006

Loss of Power - Codes P0345 / P0349


This is a discussion on Loss of Power - Codes P0345 / P0349 within the 2nd Gen - 2003 - 2006 forums, part of the Ford Expedition Forum category!
Register to remove these ads. It's free! Hi everyone, With towing season upon us... my Expy decided to give me ...



Reply
 
LinkBack Thread Tools Display Modes
Old 06-27-2013, 07:18 PM   #1 (permalink)
 
06king's Avatar
Registered User

 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 27
Default Loss of Power - Codes P0345 / P0349


Register to remove these ads. It's free!
Hi everyone,

With towing season upon us... my Expy decided to give me a couple of summer challenges :(

I have the check engine light on and when I checked, I have the following Codes P0345 / P0349... I also started to notice a bit of a loss of power...

The Codes suggest
P0345- Camshaft position sensor A circuit
P0349- Camshaft position sensor A circuit (intermittent - Bank 2)

Has anyone experienced / fixed the following issues?
Thank you for your help!
__________________


Now every time I drive, I go on an Expedition!

<><
06 Ford Expedition King Ranch
07 Ford Focus ST
93 Ford Mustang 5.0 LX
68 Ford Mustang Convt 289
06king is offline   Reply With Quote
Old 06-27-2013, 08:07 PM   #2 (permalink)
 
06king's Avatar
Registered User

 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 27
Default

I just noticed also... when I put it in neutral and rev up the engine... it also does not go over 2500 rpms... it bounces from 2500 - 3000 rpms...
__________________


Now every time I drive, I go on an Expedition!

<><
06 Ford Expedition King Ranch
07 Ford Focus ST
93 Ford Mustang 5.0 LX
68 Ford Mustang Convt 289
06king is offline   Reply With Quote
Old 07-02-2013, 09:37 PM   #3 (permalink)
 
06king's Avatar
Registered User

 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 27
Default ? No Suggestions ?

Wow! No suggestions???

I am glad I'm the only one with these codes... :)

I do have some good news...

I had the codes reset and reset and the engine light has not reappeared (after a week).

After a diagnostic, the mechanic did not find any other issues with the common triggers of the 0345 code (ex. cam sensors, phasers, etc)...

He did tell me to get a tune up, as over working coil(s) could cause an interference with the cam sensors... So change the plugs here I go :(

As for the engine bogging down, That wouldn't happen when I shifted it manually... it turned up to the tranny was shifting 3 gears almost in sequence, so it was going into ovd way too soon... we also noticed that it wasn't down shifting and getting "hang" in ovd when coming down to a stop - so not shifting down as slowing down.

This according to the tranny mechanic is due to the wearing down of the 8??check balls in the valve body...
__________________


Now every time I drive, I go on an Expedition!

<><
06 Ford Expedition King Ranch
07 Ford Focus ST
93 Ford Mustang 5.0 LX
68 Ford Mustang Convt 289
06king is offline   Reply With Quote
Old 07-15-2013, 10:16 PM   #4 (permalink)
 
06king's Avatar
Registered User

 
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 27
Default

Update... the hesitation of the engine turned out to be the tranny...

I took it apart last week... and as soon as I opened the valve body... I noticed right away a check ball with half missing... (I did find the other half in the old fluid at the end...)

Who knew the balls are a hard plastic / rubber?? :(
That was it... I guess I needed to change the filter and tranny fluid anyway :)

I had great help from this video on performing the Jmod (which I didn't do) -
__________________


Now every time I drive, I go on an Expedition!

<><
06 Ford Expedition King Ranch
07 Ford Focus ST
93 Ford Mustang 5.0 LX
68 Ford Mustang Convt 289
06king is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Dodge Ram Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Scion FR-S Forum
Softball Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum