Recent Activity

Activity stream for all registered members at Ford Expedition Forum.

  1. juan214 replied to the thread 2000 intake manifold swap.

    Even though it's in the same Gen there may be mods to be made. The swap is possible. In your case you're going backwards where I would...

    May 26, 2017 at 6:28 AM
  2. docraymund replied to the thread Factory Air Ride Lift....

    Try reading this: http://forum.expeditionportal.com/threads/50165-Air-ride-Expedition-suspension-question

    May 26, 2017 at 6:23 AM
  3. docraymund replied to the thread IN NEED OF THE ELECTRICAL GURU'S!!!.

    Try to connect a ground wire from battery negative to a clean area in the truck's body and see if fixes your problem.

    May 26, 2017 at 6:17 AM
  4. jeff kushner replied to the thread ReadyLift SST 3/2 kit 69-2070.

    Ah crap, just saw that the question I asked was right there in the thread title....here's MY sign! jeff

    May 26, 2017 at 6:09 AM
  5. Vancouver Bob replied to the thread 2003 Expedition Face Lift Begins.

    As for why the bumper... It's one of those things that just built upon itself. I really just wanted more ground clearance because I...

    May 26, 2017 at 1:42 AM
  6. 5x10 replied to the thread 2017 Expy Limited ambient lighting malfunction...still.

    left footwell, drivers side is what I read My front cup holder wasn't working very well, got it replaced under warranty Possibly just...

    May 26, 2017 at 12:34 AM
  7. Jmcreynolds86 posted a new thread.

    Mirror turn signals

    Is there any way to fix the turn arrows in the mirrors? They both work but they seem really dim at night and you can barely see then...

    Forum: 1st Gen - 1997 - 2002

    May 25, 2017 at 11:38 PM
  8. lpburke86 replied to the thread 2000 intake manifold swap.

    Yes, exactly.... what does that entail? Since no one answered, I just changed the intake manifold gaskets on mine.... but i have another...

    May 25, 2017 at 10:46 PM
  9. stamp11127 replied to the thread Electrical Short that isn't Blowing a Fuse.

    Usual culprit is the ignition switch. Disconnect one battery cable, leave the small wire that you are reading the 8.47v disconnected at...

    May 25, 2017 at 9:50 PM
  10. jonny150 posted a new thread.

    2008 expy front end grind

    I have a grind in the front end. I know these are vacuum released hubs. Only good info I can find is on f150s. Do these expeditions have...

    Forum: 3rd Gen - 2007 - 2017

    May 25, 2017 at 9:31 PM
  11. JJP1351 replied to the thread IN NEED OF THE ELECTRICAL GURU'S!!!.

    Ok. I'll check it tomorrow when it's not monsooning. Thanks. Wife went thru a puddle an hour ago and all electronics in the dash went...

    May 25, 2017 at 9:02 PM
  12. Big Brian replied to the thread IN NEED OF THE ELECTRICAL GURU'S!!!.

    I would want answers to Stamps post #4 before offering any opinions. I would also ask what is the battery voltage while all this...

    May 25, 2017 at 8:23 PM
  13. Tim Skinner replied to the thread Electrical Short that isn't Blowing a Fuse.

    well I checked to small wire going to the when the switch is off and it's reading 8.47v . it's hot even when the key is not in the vehicle

    May 25, 2017 at 6:44 PM
  14. 99WhiteC5Coupe replied to the thread Rotors and pads / factory or something else.

    The shudder goes away. It always appears at about 40 - 45 mph, when I lift the gas pedal and gently apply the brakes (such as when on a...

    May 25, 2017 at 6:06 PM
  15. stamp11127 replied to the thread IN NEED OF THE ELECTRICAL GURU'S!!!.

    Drop the lower dash cover and inspect the connectors to the various components. Pull the headlight and dimmer switch out also for...

    May 25, 2017 at 6:05 PM
Loading...