Blend door or actuator?

Discussion in 'Heating & Cooling' started by Journey, Mar 30, 2018.

  1. Journey

    Journey Member

    Age:
    31
    Posts:
    11
    Likes Received:
    0
    Joined:
    Sep 18, 2017
    Location:
    East Bay Area
    Hi all,

    1997 Expedition 5.4 XLT

    My A/C is charged (i bought a can with a gauge and checked/recharged a bit) and it blows cold in the back but not the front.

    Occasionally in the past, heat would not come out of the vents (but they would still blow air) so after turning the temp knob back and forth, it would work. Last time it did that I could hear a single snap/click sound coming from the glove box area and then the heat would work.

    Sooooooo.....do you think it's the actuator or the blend door?

    I just bought a blend door today because thats my guess....but I just want more confirmation before I take the dash out that's the only way to replace the door is take the dash out right? Which one do you think is broke?

    Thanks!
     
  2. Journey

    Journey Member

    Age:
    31
    Posts:
    11
    Likes Received:
    0
    Joined:
    Sep 18, 2017
    Location:
    East Bay Area
    Well anyways,

    The blend door was broken, i replaced them both however, i think the NAPA blend door must have been slightly bigger on the bottom round base because i spent a few hours trying to get that sucker in there with the backing plate that goes up against heater core. I managed to stuff that fucker in there and hopefully it will hold.

    This guy has a beautiful video on how to take the dash off....amen to this:

     

Share This Page