Register to remove these ads

Can't get 97 Expedition in gear. HELP!

Discussion in '1st Gen - 1997 - 2002' started by richlester, Jul 10, 2013.

  1. richlester

    richlester Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jul 10, 2013
    Location:
    Streetman, Texas
    The other day I was driving home from Academy Sports & My 1997 Ford Expedition (with automatic transmission) just suddenly stopped accellerating. The engine is running fine. But I cannot get it into gear. When I try to put it in Park, I hear gears grinding...... I checked the shift cable on both ends & it seems to be shifting properly. What else can it be? Has anyone else had this problem? Thanks in advance...
     
  2. FordandPolaris

    FordandPolaris Full Access Members

    Posts:
    2,247
    Likes Received:
    251
    Joined:
    Feb 7, 2012
    Location:
    Saint Cloud, MN
    Do you get a blinking O/D Off light on the shifting stalk? Sounds to me like it might be rebuild time. I would bring it to a shop specializing in transmissions (if you don't have AAA, time to sign up, makes towing much cheaper in the long run) and have them take a look at it.

    I had a problem a year or so ago where my truck would not shift into drive, reverse and park both worked fine. Shop pulled the pan and shifting plunger, saw nothing wrong, put it back together with new filter and fluid, and it has worked fine since. Hopefully that's all it takes.
     
  3. Bowesmobile

    Bowesmobile Full Access Members

    Posts:
    395
    Likes Received:
    42
    Joined:
    Jul 7, 2012
    Location:
    Clarkston, Mi
    Sounds like its time for a transmission rebuild. Something let loose in the trans. and is not allowing it to go into gear.
     
  4. richlester

    richlester Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jul 10, 2013
    Location:
    Streetman, Texas
    I dont get any flashing lights or anything. How much does it cost to have it rebuilt, if that's what I neeed?
     
  5. Bowesmobile

    Bowesmobile Full Access Members

    Posts:
    395
    Likes Received:
    42
    Joined:
    Jul 7, 2012
    Location:
    Clarkston, Mi
    Depending on the parts needed it can be anywhere from $1500 to $3500. Make sure whoever does it is competent. They answer all of your questions clearly and they have a good reputation. Or you can be going through the same hassle next year this time.
     
  6. Jay87LX

    Jay87LX Full Access Members

    Posts:
    455
    Likes Received:
    16
    Joined:
    Oct 2, 2011
    Location:
    Mass
    These trucks as well as the F150 counterparts are so plentiful you can find used trans for $500
     
  7. richlester

    richlester Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jul 10, 2013
    Location:
    Streetman, Texas
    That's the route I'll go if I can't get her fixed.... Gonna change the Manual Lever Position Sensor to see if that helps....
     
  8. JUST4FUN

    JUST4FUN Admin Staff Member

    Posts:
    1,941
    Likes Received:
    56
    Joined:
    Oct 25, 2005
    Location:
    Mokena Il
    If this is a 4x4 you might have a transfer case problem
     
  9. richlester

    richlester Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jul 10, 2013
    Location:
    Streetman, Texas
    It is a 4X4
     
  10. hortonguy

    hortonguy Member

    Posts:
    21
    Likes Received:
    1
    Joined:
    May 9, 2013
    Location:
    ohio
    dont waste your money on the trans range sensor your planetery gear set let go thats why it wont go into park and no flashing od light because it is a hard part not something that is electric or monitered by the pcm
     

Share This Page