Register to remove these ads

Code P0430

Discussion in 'Engine & Performance' started by hoopsta, Apr 17, 2008.

  1. hoopsta

    hoopsta New Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Feb 26, 2008
    I went to Autozone because my CEl came on and I got code P0430 this is a bad O2 or CAT CAUSED by misfire or vacuum leak or exhaust leak. I have pretty much ruled out Vacuum and exhaust leak which leaves me with the misfire I have been having.Can anyone tell me how to determine which cylinder is misfiring??? I have pulled every single one of the boots to do a visual inspection looking for water or oil in the well but they were all clean and dry. I am only getting the misfire at about 2000 RPM's when I accelerate and sometimes on the highway at around 72 MPH consistantly. I replaced the TPS about a month ago because the truck was losing power and bogging down when I stepped on the gas this fixed that problem but now I have this problem.
    I don't want to chase my tail on this and was wondering if anyone can give me some advice
    This is'nt a bad misfire yet it is just a slight bucking when I accelerate but I am worried it will get worse.
    I am moving next month and need to fix this before I have to drive 4000 miles across country.
    thanks in advance for any help.


    2003 Expedition 4.6L XLT
    71,000 miles
     
  2. JUST4FUN

    JUST4FUN Admin Staff Member

    Posts:
    1,941
    Likes Received:
    56
    Joined:
    Oct 25, 2005
    Location:
    Mokena Il
    has it ever had plugs ??
     
  3. mohs00

    mohs00 Active Member

    Age:
    31
    Posts:
    37
    Likes Received:
    0
    Joined:
    Dec 27, 2007
    Location:
    michigan
    id put some plugs in her if the havent been done and that should take care of it unless u have a bad coil but start with the plugs
     

Share This Page