Register to remove these ads

Trans od light flashing....

Discussion in '1st Gen - 1997 - 2002' started by 215Expedition, May 22, 2013.

  1. 215Expedition

    215Expedition Full Access Members

    Posts:
    130
    Likes Received:
    1
    Joined:
    Mar 3, 2013
    Location:
    Philadelphia
    While driving home from work yesterday I happen to look down at my radio and saw my OD light flashing. I was doing about 65-70 and did not notice and shift problems until i got off the exit and noticed a very slight bump when it was going into 2nd and then third gear. I pulled over shut it off then back on and no more light or bump i drove around for another hour and it never happened again. then again this morning at the same speed it did it again so i again cut it off and started it back up and it went away i have been driving all day with no issues. where are the codes stored from the tranny? i went to auto zone and got the cel scanned and got a code p0401 and something about bank one oxygen sensor. any ideas?????
     
  2. toms89

    toms89 technical advisor

    Posts:
    5,171
    Likes Received:
    416
    Joined:
    Mar 13, 2011
    Location:
    MD

    [​IMG]

    O/D light flashing means the pcm has recognized an issue with the transmission. Can be many things....

    Resetting the light is not going to make the problem go away so just drive normal. Unfortunately I do not believe you can read any codes related to the tranny. May have to go to dealer or transmission specialty shop.
     
    Last edited: May 22, 2013
  3. 215Expedition

    215Expedition Full Access Members

    Posts:
    130
    Likes Received:
    1
    Joined:
    Mar 3, 2013
    Location:
    Philadelphia
    OK thanks for the info, I might have to take it to a transmission shop to get it looked at. I don't think its anything bad as of yet because it comes and goes but i hope its a simple fix.
     
  4. BANGEREXPO76

    BANGEREXPO76 Full Access Members

    Posts:
    105
    Likes Received:
    0
    Joined:
    Jan 18, 2013
    Location:
    PLUGZONE 76
    I had this similar problem and It is probably not your trans. I took mine to the trans shop first and he was a good fellow and told me I didn't have a problem. He had it hooked up to the big mobile scanner. Being that you have code 401 I'm guessing your cat converters are clogged. Mine were clogged up with what looked like concrete. They were so bad I had them leave the rear ones off and run straight pipe. The truck instantly ran GREAT and still does to this day!!! I also replaced all 4 O2 sensors. Just throwing that out there. Good luck with yout truck.
     
  5. Firepuppy

    Firepuppy Active Member

    Posts:
    30
    Likes Received:
    0
    Joined:
    Sep 8, 2010
    Location:
    Rome NY
    same issue

    i had a 99 expo that the OD light was flashing on it if im correct you can count the flashes and it will be the code the reason mine was flashing was because of the shift modules so i watched you tube to see how to change the shift modules and i tackeled it one weekend and changed all 3 shift modules and the wiring cost me about 50 in parts and no more flashing od and that was about 2 years ago still running strong with 250,000 on it
     
  6. 215Expedition

    215Expedition Full Access Members

    Posts:
    130
    Likes Received:
    1
    Joined:
    Mar 3, 2013
    Location:
    Philadelphia
    Come to find out the egr valve was clogged took it off and cleaned it and now no problem.
     

Share This Page