2003 EXPEDITION CLUSTER OUTSIDE TEMPERATURE, COMPASS & ODOMETER DISPLAY FLASHES, BLINKS WHY ?

Discussion in 'Electrical' started by SEPTIC PROFESSOR, Sep 30, 2018.

  1. SEPTIC PROFESSOR

    SEPTIC PROFESSOR Full Access Members

    Age:
    64
    Posts:
    90
    Likes Received:
    18
    Joined:
    Jan 2, 2018
    Location:
    SARASOTA
    This vehicle is the XLT with analog instrument cluster.
    At random times the display lower right side of instrument cluster that contains the outside temperature, compass and odometer flashes or blinks
    DIM-NORMAL-DIM-NORMAL. 4 clicking sounds similar to a directional signal flasher are heard near driver left knee lower dash cover whenever this happens. The flashing/blinking stops after the 4 events (DIM-NORMAL-DIM-NORMAL) occur and then recurs at random times. Sometimes days or weeks go by between these occurrences. Everything else electrical works fine.
    I'm wondering if any other members have experienced this and if so did they have any success correcting this.
    Sometimes when I go to start the truck it won't crank unless I hit the door unlock button once on the driver door and I don't know if that is normal.
    Thanks in advance for your help !
     
  2. joethefordguy

    joethefordguy Full Access Members

    Posts:
    65
    Likes Received:
    10
    Joined:
    Apr 10, 2017
    Location:
    Texas
    not to hijack your thread, but where is the sensor for outside air temperature?
    I've got the 04; which I suspect is not much different from yours. Also the XLT with the analog instrument cluster. my outside air temp went to 106 yesterday in a matter of minutes, even though I was parked in the shade (engine was idling; engine temp never got above the midpoint of the engine temp gauge). I checked a weather report, actual outside temp was 97.
    once I got moving, outside temp dropped to 100 in less than ten minutes.
    anybody got a clue?
    thanks for your time.
    jg
     

Share This Page