2012 Expedition Running Boards Issue

Discussion in '3rd Gen - 2007 - 2017' started by LouG, Feb 14, 2017.

  1. ManUpOrShutUp

    ManUpOrShutUp Full Access Members

    Posts:
    1,057
    Likes Received:
    369
    Joined:
    Mar 27, 2016
    Location:
    Northeast
    I use white lithium, but it's all largely irrelevant. They're very likely to fail prematurely no matter what you do unless you drive it primarily in dry, non-dusty conditions pretty much all the time.
     
  2. star-art

    star-art Full Access Members

    Posts:
    443
    Likes Received:
    119
    Joined:
    Aug 23, 2010
    Location:
    Pacific Northwest
  3. JExpedition07

    JExpedition07 Winterized Member Supporting Member

    Posts:
    4,878
    Likes Received:
    2,037
    Joined:
    Mar 30, 2017
    Location:
    New York
    Power running boards are one option I’ve never liked in the northeast.
     
    Last edited: Dec 15, 2019
  4. Jon1985

    Jon1985 Active Member

    Age:
    34
    Posts:
    29
    Likes Received:
    7
    Joined:
    Sep 2, 2017
    Location:
    Cinnaminson NJ
    My passenger running board motor went out about a month ago on my 2010 EL limited. I know the motor is shot sounds horrible makes a loud Er Er Er Sound if I force it up it will go but will fall back down if I start driving .i also used PB Blaster on them always so don’t think rust is the problem. I actually just unplugged both motors for each side covered the plugs but I think that was a mistake because out of no where my battery died for no reason . My guess would be the computer was trying to close them still while off . So I plugged them back in left them in the down position and then pulled the fuse. Also don’t go in a car wash with them down I nicked up my driver side running board the plastic end piece from the tire cleaner. I’m going to buy one of those Chinese replacement motors on eBay in the spring to fix it I’m not buying brand new running boards from ford all I need is the motor .
     
  5. Ghostwolf

    Ghostwolf Member

    Posts:
    20
    Likes Received:
    9
    Joined:
    Nov 19, 2019
    Location:
    Ann Arbor, MI
    The process I use at the car wash is to lower the running boards for the initial drive in and wash by the guys with the power wash wands and brushes. Then I raise them for the trip through the rest of the wash so they don’t hit anything.
     
  6. Julian

    Julian Member

    Posts:
    8
    Likes Received:
    4
    Joined:
    Jan 8, 2019
    Location:
    Winnipeg
    A wash and WD-40 worked on my '14 driver side running board for the past month. So far it works without help again. Before it would try a little, stop and go back down.
    Will try the motorcycle lube another poster mentioned if WD-40 doesn't cut it.
     

Share This Page