2018 PLATINUM SUDDEN/INTERMITTENT POWER FAIL?!?

George Hanson

Member
Joined
May 19, 2022
Posts
19
Reaction score
15
Location
Milwaukee, WI
My sister purchased a CPO 2018 Platinum (white) in Oct. ‘20 with ~45k miles.

A couple times on local/small roads the vehicle suddenly lost power but she didn’t think much of it. After the 3rd instance she took it to her local guy and he couldn’t find anything wrong.

About 2 weeks ago on the highways around Chicago it happened in the left lane at speed and in heavy traffic…scared her BADLY. The vehicle coasted down to about 40mph and just as suddenly the power came back and she was able to make it home.

At this point she got me involved and I directed her to take it to the dealer (luckily still inside the 5yr/60k power train window).

Dealer said Ford’s “help desk” acknowledges the problem and confirms “6 or 7 other cases“ but “currently there’s no remedy” that they are “comfortable giving out to the Ford technicians”…

Thoughts?
 
Last edited:

99WhiteC5Coupe

Full Access Members
Joined
Jun 3, 2015
Posts
1,808
Reaction score
785
Location
USA
My sister purchased a CPO 2018 Platinum (white) in Oct. ‘20 with ~45k miles.

A couple times on local/small roads the vehicle suddenly lost power but she didn’t think much of it. After the 3rd instance she took it to her local guy and he couldn’t find anything wrong.

About 2 weeks ago on the highways around Chicago it happened in the left lane at speed and in heavy traffic…scared her BADLY. The vehicle coasted down to about 40mph and just as suddenly the power came back and she was able to make it home.

At this point she got me involved and I directed her to take it to the dealer (luckily still inside the 5yr/60k power train window).

Dealer said Ford’s “help desk” acknowledges the problem and confirms “6 or 7 other cases“ but “currently there’s no remedy” that they are “comfortable giving out to the Ford technicians”…

Thoughts?


Any stored codes?

Sounds like a problem with the throttle body and/or its wiring, or loose or corroded battery terminal cable connectors.
 

99WhiteC5Coupe

Full Access Members
Joined
Jun 3, 2015
Posts
1,808
Reaction score
785
Location
USA
Posted a pic above.

Tx to all for feedback.


The stored code is related to the transmission range selector.

I’m speculating - but perhaps the transmission selector switch is bad (or has an intermittent problem) - which causes the engine to lose power?

I’m surprised the dealer was unable to find a solution, despite the stored code.

Keep us updated and good luck.
 
Top