AC Pressure Relief Valve woes

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Motorcity muscle

Full Access Members
Joined
May 6, 2018
Posts
597
Reaction score
216
Location
Motorcity
As suggested the only way to know the system pressures while running is with gauges, safety valve could be faulty or saving your life.
 
OP
OP
H

heuster

Well-Known Member
Joined
Sep 18, 2016
Posts
46
Reaction score
1
Location
Arizona
I wish I could provide what you're asking, I just can't. It can't be recreated I can't cause it to happen and by the time I get my gauges on if it happens start doing it where I actually have them, all my refrigerant is going to be gone.

Is there anyone that can help to determine if this is happening, "X" is generally going to be the cause? (Like a blockage in the condenser, or a bad expansion valve) I don't know where to start and I don't want to replace everything. I'm trying to give you all the information I can.
 
OP
OP
H

heuster

Well-Known Member
Joined
Sep 18, 2016
Posts
46
Reaction score
1
Location
Arizona
**UPDATE** I had to do something. So, I installed a new condenser, dryer, expansion valve, orifice tube, and front manifold lines. Filled with 62oz of refrigerant and it's blowing at about 70 degrees. If I raise the RPMs to around 2k, it does come down to around 60 degrees. Low side pressure is 70, high side is 390 steady. Doesn't change unless I add RPM. At rest the system equalizes at 150. Compressor might have 2000 miles on it (Denso.)

Is there anything you can tell me with this info? I'm really tryin to get all the information together, but I need your help and experience. Please.
 

Dobermans

Member
Joined
Apr 25, 2023
Posts
17
Reaction score
10
Location
CA
I recently replaced all my ac. I honestly can’t think off hand what it could be. My ac use to get warm without more rpm’s before I replaced it, it did that because it was low on refrigerant. But you just filled yours. Maybe check fuses, see if it’s throwing codes. I have read about people having problems with aftermarket fan clutch’s, but that would not effect your ac. Good luck I’ve been in those situations where you can’t figure out what’s wrong.
 

Hamfisted

Full Access Members
Joined
Nov 20, 2012
Posts
2,633
Reaction score
1,510
Location
Ft Lauderdale
**UPDATE** I had to do something. ... Low side pressure is 70, high side is 390 steady. Doesn't change unless I add RPM. At rest the system equalizes at 150. Compressor might have 2000 miles on it (Denso.)

Is there anything you can tell me with this info? I'm really tryin to get all the information together, but I need your help and experience. Please.

Both your Low and High pressures are way too high. You need 40-45 psi on the Low side and should see 200-250 on the High side. Let some gas out.
 

Timo2824

Full Access Members
Joined
Aug 18, 2021
Posts
147
Reaction score
88
Location
Wichita
None condensables in the system, how are you pulling a vacuum? In the AC industry we pull a vacuum down to 500 microns, are you using a micron gauge?
 

Motorcity muscle

Full Access Members
Joined
May 6, 2018
Posts
597
Reaction score
216
Location
Motorcity
Relief valve is saving your life, 390# high side is dangerous. When gauges are attached, is the high side gauge needle steady? Assuming we are talking about your '01, only expy with 62 oz. charge and 11 oz of pag. So you added 8 oz's to a system that only holds 11 oz and already had oil in it. Proper procedure would be to drain and measure the oil in the compressor before replacing. Most of the oil charge lays in the bottom of the condenser and the compressor, when the system is off. There is no doubt you have way to much refrigerant in system with those pressures, how are you weighing in the refrigerant? What did you use besides air to flush lines? Air will not remove all of the oil.
 
OP
OP
H

heuster

Well-Known Member
Joined
Sep 18, 2016
Posts
46
Reaction score
1
Location
Arizona
None condensables in the system, how are you pulling a vacuum? In the AC industry we pull a vacuum down to 500 microns, are you using a micron gauge?
With an AC vacuum - it pulls down past 0 on the gauges and I let it run for about 45 minutes then let it sit for a couple hours and make sure the needle hasn't moved.
 

Latest posts

Staff online

Forum statistics

Threads
54,136
Posts
506,229
Members
48,078
Latest member
Wayneo
Top