Blinkers not work

Discussion in 'Electrical' started by Tressica garza, Aug 22, 2018.

  1. Tressica garza

    Tressica garza New Member

    Age:
    34
    Posts:
    2
    Likes Received:
    0
    Joined:
    Aug 22, 2018
    Location:
    Kennewick
    Some One please help me my blinkers aren’t working but hazards are I replaced the relays he multi function switch and the fuse and input would be much appreciated I have a 2003 Ford Expedition
     
  2. 1955moose

    1955moose Full Access Members

    Posts:
    4,075
    Likes Received:
    695
    Joined:
    Nov 23, 2014
    You might want to repost on Expedition second gen section. For some reason most don't bother with these other sections. First thing though I'd do is find the fuse for your signals and see, 1 if you have power both sides, and in fact it's not blown. Are you working on vehicle? Or is someone else? The chances of all four bulbs out are slim to none, but you or whomever is doing work will have to start at fuse block and make their way back. It's possible you have a wonky flasher relay. Changed mine about 1 month back. My symptoms were it would flash then stop 5-10 seconds later. Let us know what's up, and repost in the section I mentioned

    Sent from my N9131 using Tapatalk
     
  3. stamp11127

    stamp11127 Super Moderator Staff Member

    Age:
    61
    Posts:
    5,476
    Likes Received:
    817
    Joined:
    Mar 10, 2012
    Location:
    Temple, Georgia
    Fits just as well I the electrical section. Plus as a new member he didn't post it in the New Member section like a few have done in the past.
     

Share This Page