Cabin air smell from vents – leaking evaporator core?

Discussion in 'Heating & Cooling' started by bigcars, Oct 7, 2019.

  1. bigcars

    bigcars Active Member

    Age:
    46
    Posts:
    25
    Likes Received:
    5
    Joined:
    Dec 30, 2016
    Location:
    Central PA
    2015 Expedition with almost 90K. Weird smell coming from the vents. Started out of the blue. Dealer says is it refrigerant. They evacuated the AC system and said it was not full, therefore must be a leak. No external leaks, therefore it must be the evaporator core – and big replacement expense. I decided to sit on it a bit, after all, I can do without AC in the winter. They did not recharge the system. My theory was that the smell would dissipate if the system was empty. But it is still there. Just doesn’t seem to be adding up and not sure what to do next. They also told me they’ve seen this in F-250s and that the Expedition is set up similar to that.
     
  2. igneous

    igneous Full Access Members

    Posts:
    52
    Likes Received:
    2
    Joined:
    Jan 13, 2013
    Location:
    Texas
  3. igneous

    igneous Full Access Members

    Posts:
    52
    Likes Received:
    2
    Joined:
    Jan 13, 2013
    Location:
    Texas
    These things worked great in my expy, but you have a more serious issue.
     
  4. bigcars

    bigcars Active Member

    Age:
    46
    Posts:
    25
    Likes Received:
    5
    Joined:
    Dec 30, 2016
    Location:
    Central PA
    Thanks igneous. Looks like a good product. If I could just pack the air ducts with these. For whatever reason the 2015s don't even have a cabin air filter.
     

Share This Page