Dashboard Dimmer Problem

Discussion in '3rd Gen - 2007 - 2017' started by Ghostwolf, Nov 20, 2019.

  1. Linksvu

    Linksvu Member

    Age:
    37
    Posts:
    14
    Likes Received:
    1
    Joined:
    Jul 28, 2019
    Location:
    Littleton CO
    Now that is is working, does it illuminate when the lights are turned on? I'm having a similar issues, but my switch only responds intermittently to dimming.

    How much the part?
     
  2. Langer

    Langer Full Access Members

    Age:
    32
    Posts:
    131
    Likes Received:
    72
    Joined:
    Mar 27, 2019
    Location:
    Chicago
    yes, when running lights or headlights are on it is illuminated.
     
  3. Ghostwolf

    Ghostwolf Member

    Posts:
    20
    Likes Received:
    9
    Joined:
    Nov 19, 2019
    Location:
    Ann Arbor, MI
    Like Langer said, yes, the switch illuminates when the headlights are on.

    The part number (for my 2016) is BC3Z-11691-AA and lists for around $40 but you can find it on Amazon for around $29. My local Ford dealer runs a internet parts store and discounts to about 20% (varsityfordparts.com). Since I can pick up from them locally, I can avoid shipping costs and paid $13.35 for the part.

    I would suggest that you check the connection at the switch and see if it’s secure. In my case, it was just loose. It’s easy to reach if you remove the bottom half of the steering wheel shroud (3 screws from underneath).

    If it turns out that your connection is secure and the switch is still flakey, let me know; you can buy mine and I’ll ship it to you.
     
  4. turtle019

    turtle019 Member

    Age:
    29
    Posts:
    14
    Likes Received:
    5
    Joined:
    Oct 15, 2019
    Location:
    MI
    I had the same issue when I bought my '17 used. Would yours happen to be a formerly Canadian vehicle also? For mine I just figured they forgot to reconnect it when swapping the speedometer to mph
     
  5. Linksvu

    Linksvu Member

    Age:
    37
    Posts:
    14
    Likes Received:
    1
    Joined:
    Jul 28, 2019
    Location:
    Littleton CO
    Thanks. I mine was operator error. I did not realize there was a 'soft touch' for the dimming and then a hard touch to turn the overhead lights on. So far, mine is working as I think it should now.
     
  6. Ghostwolf

    Ghostwolf Member

    Posts:
    20
    Likes Received:
    9
    Joined:
    Nov 19, 2019
    Location:
    Ann Arbor, MI
    That’s an interesting theory, especially since my Expedition was originally sold on Quebec. You’re probably correct.
     

Share This Page