Dome lights cutting on/off and relay or fuse clicking?

Discussion in '1st Gen - 1997 - 2002' started by Djarratt2607, Apr 16, 2019.

  1. Djarratt2607

    Djarratt2607 Member

    Age:
    19
    Posts:
    20
    Likes Received:
    2
    Joined:
    Mar 31, 2019
    Location:
    North Carolina
    So I just came home from a 5 day vacation.. Went to start my 99 expedition eddie Bauer 5.4, and with the truck off and driver door open the dome lights were dim and cutting on/off (engine off, keys OUT of ignition). Along with that, there is a clicking noise coming from under the dash with each flicker of the lights. I shut the door, locked it and watched it for about 30 minutes and it doesn't happen with the doors closed. Any ideas? And considering it doesnt seem to happen with the doors closed, how did it manage to kill my battery while I was gone?

    Sent from my SM-G965U using Tapatalk
     
    Last edited: Apr 16, 2019
  2. Machete

    Machete My Rig. 2000 EB 4x4 5.4L

    Posts:
    244
    Likes Received:
    62
    Joined:
    Jul 18, 2012
    Location:
    Illinois
    Short circuit
     
  3. Djarratt2607

    Djarratt2607 Member

    Age:
    19
    Posts:
    20
    Likes Received:
    2
    Joined:
    Mar 31, 2019
    Location:
    North Carolina
    How would I go about checking that? & i know my alternator has a bad bearing, could it be possible that it has gone out?

    Sent from my SM-G965U using Tapatalk
     
  4. lvcjt702

    lvcjt702 Full Access Members

    Age:
    40
    Posts:
    126
    Likes Received:
    42
    Joined:
    Aug 13, 2017
    Location:
    Lost Wages
    Check your aux lighting relay. You've probably got a windshield leak.

    Sent from my SM-G935P using Tapatalk
     
    Trainmaster likes this.
  5. Djarratt2607

    Djarratt2607 Member

    Age:
    19
    Posts:
    20
    Likes Received:
    2
    Joined:
    Mar 31, 2019
    Location:
    North Carolina
    No signs of windshield leak and all fuses are fine. But honestly I don't know how to check relays? Never had a problem with one.

    Sent from my SM-G965U using Tapatalk
     
  6. lvcjt702

    lvcjt702 Full Access Members

    Age:
    40
    Posts:
    126
    Likes Received:
    42
    Joined:
    Aug 13, 2017
    Location:
    Lost Wages
    1 Open owners manual.

    2 Find under dashboard fuse box diagram.

    3 Locate auxiliary lighting relay on diagram.

    4 Locate auxiliary lighting relay in under dashboard fuse box.

    5 Remove auxiliary lighting relay from under dashboard fuse box.

    6 Take auxiliary lighting relay to auto parts store.

    7 Purchase replacement relay that matches auxiliary lighting relay.

    8 Go to parking lot.

    9 Insert new relay into auxiliary lighting relay position.

    10 Open and close doors.

    11 Have new auxiliary lighting relay cause same issues as old auxiliary lighting relay.

    12 Search forum and discover that ecu has water damage from windshield leak due to length of solid body vehicle.

    Or at least thats how I diagnosed your exact symptoms. Let us know how it turns out.

    Sent from my SM-G935P using Tapatalk
     
  7. Bilsto

    Bilsto Member

    Age:
    53
    Posts:
    14
    Likes Received:
    1
    Joined:
    Nov 13, 2018
    Location:
    Nashville TN
    My 2000 model did the exact same thing. It ended up seeming like a low-battery warning. I replaced the battery and the problem is gone.
     

Share This Page