Howdo I Smoke Test the EVAP System (2005 Expedition)

David E

Well-Known Member
Joined
Jul 20, 2020
Posts
55
Reaction score
17
Location
Damascus, MD
Hello to all,
Recently got the elusive P0457 (Leak Detected/Fuel Cap loose/off) and after testing the fuel cap using a replacement and replacing the Fuel Pressure sensor switch (at the tank) as well as the Fuel rail pressure and temperature sensor I got nowhere. Still have the code after a drive cycle and wanting to do a smoke test. Made me a small smoke machine out of 5.56 box.. and don't really know where to connect it to. Was hoping someone here can help with connection area and conditions. (engine running vs off.)
Thanks in advance.
2005 Expedition 5.4 3v V8 KR.
 
Last edited:

99WhiteC5Coupe

Full Access Members
Joined
Jun 3, 2015
Posts
1,358
Reaction score
571
Location
USA
Hello to all,
Recently got the elusive P0457 (Leak Detected/Fuel Cap loose/off) and after testing the fuel cap using a replacement and replacing the Fuel Pressure sensor switch (at the tank) as well as the Fuel rail pressure and temperature sensor I got nowhere. Still have the code after a drive cycle and wanting to do a smoke test. Made me a small smoke machine out of 5.56 box.. and don't really know where to connect it to. Was hoping someone here can help with connection area and conditions. (engine running vs off.)
Thanks in advance.
2005 Expedition 5.4 3v V8 KR.


I may be wrong - but I think the EVAP codes reset takes several drive cycles (with full warm up and cool down), to reset.
 

Hamfisted

Full Access Members
Joined
Nov 20, 2012
Posts
1,514
Reaction score
699
Location
Ft Lauderdale
The vacuum line that comes off the purge control valve runs back to the EVAP system and is easy to access there at the firewall.
 

Going_Going_Gone

Full Access Members
Joined
Aug 31, 2018
Posts
251
Reaction score
114
Location
Phoenix
"I may be wrong - but I think the EVAP codes reset takes several drive cycles (with full warm up and cool down), to reset."

Either that, or maybe disconnect the battery negative cable for ten minutes to clear the codes. You'll probably lose your seat and radio presets though
 

Forum statistics

Threads
46,146
Posts
438,220
Members
34,790
Latest member
Gegjr
Top