SCT XCal 4

joezek

Full Access Members
Joined
Jul 20, 2010
Posts
342
Reaction score
14
Location
psl, FL
Recently programmed my 08 Expedition with an Xcal 4. I'm currently using tunes from SSI Performance. They (SSI Performance) are very quick to respond to any and all questions via text, email and phone.

Over the weekend I was all ready to tow the boat for the day, Father's Day weekend, lots of people and plans for the day. I had decided to make a quick adjustment to the idle speed before leaving the house. Well......- the Xcal appeared to work normally but then went to restart and no crank. Spent hours checking fuses, voltage, and everything I could think of. I called SSi and they called me back within minutes. This was early Saturday morning in FL. They said the SCT is the problem, some kind of glitch happened and the truck PCM is in a protect mode. The SCT says unable to communicate and won't let me do a damn thing, not even return to stock.

I called SCT's "Emergency" weekend support line while SSi also contacted SCT because they know someone there. A few hours went by and nothing happened. I had a bunch of people waiting on me and the boat. I had to use the mower to drag the truck into the front yard and get another vehicle to tow the boat. I finally got an email, not even a phone call, from SCT. Luckily I checked my phone every 5 minutes all day. I sent them ALL the vehicle info they asked for like strategy, VIN, SCT serial number etc. NOTHING happened the rest of the day, nothing at all, no support. Sunday morning around 11 SCT actually called and asked for the Stock file so they could modify it. Within minutes I sent it to them, and again NOTHING happened. When I had them on the phone I told him I can't get to work Monday if they can't help. SCT said no problem, they're closed monday for "Juneteenth" but will definitely send me the file with instructions shortly. I spent the entire rest of the day trying to reach SCT and got absolutely nowhere. They went totally silent, never responded to my messages, could not get them to call me, same as Saturday.

Now it's Monday, truck still broken day 3, and SCT has completely failed at even attempting to help me. They get an F- on customer service. All I got was a fake attempt to contact me in the morning and act like they'd help, but abandoned me afterwards. I could understand if they sent me something to upload and we couldn't figure it out, but they just totally blew me off knowing my situation. Even if they were sitting around waiting on the file and never got it (even though I sent it via reply to their email), they should have called and said still waiting on the file.

The tuner itself is pretty basic. It has a couple built in gauges I could use in case I don't want to look at my dashboard that already has gauges. There's the option to install custom tunes, or return to stock, or to do minor adjustments like adjust idle speed and timing. I thought it was supposed to be almost failsafe, and if there was a problem, they advertise their "weekend support team". Do not rely on any of that, it's just typical advertising and their support totally failed and abandoned me, they totally let me down.

Joe
 
OP
OP
joezek

joezek

Full Access Members
Joined
Jul 20, 2010
Posts
342
Reaction score
14
Location
psl, FL
UPDATE: On Monday, they day they said they were closed for Juneteenth, late in the afternoon I received a file with instructions to perform the update and recovery. I tried it and it actually worked. There was never any explanation as to why they didn't respond over the weekend like they told me they would, and they never responded to any of my questions I had as far as doing the recovery of the unit since their directions were giving me different options than the tuner. I fumbled through it though and it all worked out.
 

Members online

Forum statistics

Threads
49,256
Posts
467,089
Members
40,554
Latest member
kkag
Top