Shift Sys fault?

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

dave91gt

Well-Known Member
Joined
Jul 28, 2012
Posts
55
Reaction score
29
Location
wv
Anybody seen this alert? Our 2019 Stealth just started popping this up at times when using the rotary knob. It doesn't seem to affect it and will clear on a restart. Expy has 34K. I do have an issue with the right rear taillight getting condensation. The fault first appeared after a super heavy rainstorm and disconnecting the battery kept it off for a few days. It reappeared after I washed it. My daughter also noticed the brake light on that side didn't illuminate the morning after I washed it, although it did later when I checked. Fortunately, I sent a picture to the dealer of the condensation and he ordered a replacement taillight (over $1,000). 3/36 expires in June. Anyway, just wondering if anyone has seen this alert and has any input. Searching turns up very little.
I'm not convinced the taillight issue is driving the fault.
I did connect my handheld code reader when the wrench light was illuminated and it did not detect any codes.
 

Fastcar

Full Access Members
Joined
Dec 14, 2013
Posts
567
Reaction score
316
Location
FL
They cost soo much money 'cause there is a shit load of electrical in there. If you are getting water and it is shorting or grounding a camera or some other sensor it could very well be your problem. Good luck with it.
 
Top