1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Start up

Discussion in '2nd Gen - 2003 - 2006' started by Ice Man 62, Oct 28, 2020.

  1. Ice Man 62

    Ice Man 62 Member

    Age:
    61
    Posts:
    9
    Likes Received:
    2
    Joined:
    Jun 17, 2020
    Location:
    fort smith, Arkansas
    Ok, I have a second gen expedition with the 4.9 ltr. The problem is that on start up the fast idol will almost reach 2x rpms sometimes and remain there for almost 1minute. The other problem is the heater. Temp gauge reads normal but the air doesn't seem to get hot enough. Thermostat?. Where do I start. Thanks.
     
  2. riphip

    riphip Full Access Members

    Age:
    68
    Posts:
    288
    Likes Received:
    64
    Joined:
    Nov 6, 2018
    Location:
    Memphis, TN.
    Probably the inline heater valve over the left (P side) valve cover. May also be a leaking/bad vacuum line in same area. You can check rockauto.com for lines. Replaced all of my vac lines & that valve right after I purchased my 2004 EB. No problems since
     
    Ice Man 62 likes this.
  3. Hamfisted

    Hamfisted Full Access Members

    Posts:
    1,027
    Likes Received:
    380
    Joined:
    Nov 20, 2012
    Location:
    Ft Lauderdale
    Thermostat might be a good place to start. Especially if it's the original one still in there. I'm currently using one of the Motorad High Flow 180 thermostats from Rock Auto and it performs very well ( you will need a new gasket...). Also if you have an infrared heat temp gun see what temperatures you're getting before and after of the hot water valve there in the heater hoses that feed the heater core in the dash.


    https://www.amazon.com/Etekcity-Las...id=1603938055&sprefix=infrared,aps,244&sr=8-9


    https://www.rockauto.com/en/catalog....4l+v8,1411119,cooling+system,thermostat,2200
     
    Ice Man 62 likes this.
  4. Yupster Dog

    Yupster Dog Full Access Members

    Age:
    53
    Posts:
    415
    Likes Received:
    220
    Joined:
    Dec 7, 2018
    Location:
    Virginia
    Did you replace the radiator recently?
     
  5. Ice Man 62

    Ice Man 62 Member

    Age:
    61
    Posts:
    9
    Likes Received:
    2
    Joined:
    Jun 17, 2020
    Location:
    fort smith, Arkansas
    No, it's been like this since I bought it. So about 3 years.
     

Share This Page