Stuttering and Stalling

Discussion in '2nd Gen - 2003 - 2006' started by Average Joe, Dec 14, 2019.

  1. Average Joe

    Average Joe Member

    Age:
    30
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Location:
    Fayetteville, TN
    I have an 03 EB 5.4 Expy. I changed out all the coil packs 2 days ago and when I went to leave for work I had to pump the gas to get it to start. When I put it into Drive or Reverse, it immediately stalled. It had a really rough idle sitting close to 700 RPMs. I replaced the hose and the one next to it just to be safe, idle got better but still stalled. I then proceeded to the IAC valve. Again, there was improvements but was still stalling. Today I did a transmission flush. I needed to do it anyways but had a feeling the stalling was due to bad fluid and the torque converter. After I was done, the start up was much better the first chance and it didn't stall right away but it is still doing it. I have replaced the gas cap and the pressure feedback sensor today, checked for possible vacuum leaks using break cleaner. It still struggles to start and when pressing the accelerator while in park, it stutters. It has 149k miles and in the 3 years I have owned it I have replaced the fuel pump, fuel filter, charcoal canisters, gas cap, filler neck, EGR valve, IAC, EVAP pressure sensor, Coil packs, spark plugs, and various vacuum hoses that over time were breaking. Nothing new has popped on the CEL and I am at a loss of what could be the issue.
     
  2. Hamfisted

    Hamfisted Full Access Members

    Posts:
    727
    Likes Received:
    216
    Joined:
    Nov 20, 2012
    Location:
    Ft Lauderdale
    Do you have access to a fuel pressure test gauge ? Check the fuel pressure there at the rail. Should be 40-50 psi. Do you have access to a smoke test machine ? I would smoke test the intake system to find any hidden vacuum leaks. You've thrown a lot of parts at it already so I hate to recommend anymore right off the bat. You said you replaced a hose, but which one ? I assume a vacuum hose but there are many. It would be handy if it would throw a code just to point to a direction to look. I like to use starter fluid rather than brake cleaner. You don't hear any weird noise from the exhaust right ?


    https://www.amazon.com/OTC-5630-Fue...?keywords=Actron+CP7818&qid=1576376819&sr=8-3


    https://www.ebay.com/itm/Automotive...:f6wAAOSwxUJd2iKk:sc:USPSPriority!33065!US!-1
     
  3. Average Joe

    Average Joe Member

    Age:
    30
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Location:
    Fayetteville, TN
    I have replaced both hoses coming from the pressure feedback sensor yesterday. I don't have access to the fuel pressure tester or a smoke test machine, not without buying them. As for the exhaust noise, I did find something that you can only hear if you are under the vehicle. It sounds like something was leaking but it was coming from inside the muffler.
     
  4. Hamfisted

    Hamfisted Full Access Members

    Posts:
    727
    Likes Received:
    216
    Joined:
    Nov 20, 2012
    Location:
    Ft Lauderdale
    Give your local AutoZone a call and see if they have a fuel pressure test gauge to loan out, and a smoke test machine. Some do, some don't. Do you feel and hear a normal exhaust flow from the tail pipe ?
     
  5. Average Joe

    Average Joe Member

    Age:
    30
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Location:
    Fayetteville, TN
    No, its just like the idle, its sporadic. I will see if they have one tomorrow. I may go ahead and clean out the intake body just to be sure there are no clogs or build up. A code would be really nice right about now. I'm wondering if I don't have one because I have not driven long enough to get it to throw one.
     
  6. Average Joe

    Average Joe Member

    Age:
    30
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Location:
    Fayetteville, TN
    This morning, I went out to start up the expy. Started on first try and I ran the codes just to see if anything new popped up. I have 3 new codes that relate to possibly what is going on. There is a P0406, P0122, and a P0113. I am looking into the 3 now to see if there could be one causing the other 2. Will update once I find out more.
     
  7. Ulver

    Ulver Full Access Members

    Age:
    30
    Posts:
    89
    Likes Received:
    20
    Joined:
    Feb 21, 2019
    Location:
    Tennessee
    Hey fellow Tennesseean, I just recently went to Autozone for a fuel pressure gauge, and they let me use theirs in the parking lot without having to go through the loaner process. Instead I just handed them my ID to hold and used theirs for free.
     
    Average Joe likes this.
  8. Average Joe

    Average Joe Member

    Age:
    30
    Posts:
    5
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Location:
    Fayetteville, TN
    I just replaced the TPS and EGR solenoid, its running much better but still stalling. I have one more code that is left which is the IAT, this may be the issue because it sends data to the MAF for air intake.
     

Share This Page