Weird Problem with interior dome light

Discussion in '3rd Gen - 2007 - 2017' started by Mubarakma, Oct 28, 2019.

  1. Mubarakma

    Mubarakma Full Access Members

    Posts:
    87
    Likes Received:
    16
    Joined:
    Aug 1, 2016
    Location:
    Saudi Arabia
    Hello everyone
    I have weird problem with interior dome light on my Expedition 2010 they are working only with door openings and by dimmer switch and not working when I press manually by their switch for all of them the only way to get them on either by door openings or dimmer switch BTW they are LEDs and they are working properly till rear right passenger stopped working I tried to replace it but it seems that there is no power coming to the light socket anyone face the same issue ?
    Is it linked with LEDs?
    Thank you in advance.
     
  2. Mubarakma

    Mubarakma Full Access Members

    Posts:
    87
    Likes Received:
    16
    Joined:
    Aug 1, 2016
    Location:
    Saudi Arabia
    UP
     
  3. turtle019

    turtle019 Member

    Age:
    29
    Posts:
    7
    Likes Received:
    5
    Joined:
    Oct 15, 2019
    Location:
    MI
  4. 762mm

    762mm Full Access Members

    Age:
    39
    Posts:
    325
    Likes Received:
    168
    Joined:
    Aug 28, 2019
    Location:
    Quebec, Canada
    Yup. Fixed it by replacing the 10A fuse #25 in fuse box.

    (long story short, lol!)
     
    Mubarakma and Langer like this.
  5. Mubarakma

    Mubarakma Full Access Members

    Posts:
    87
    Likes Received:
    16
    Joined:
    Aug 1, 2016
    Location:
    Saudi Arabia
    Thank you very much guys .I have replaced mentioned blows fuse so problem solved and still there is one more problem it seems that the rear dome light malfunction in both driver and passenger side one of them not working at all and other one not working properly .
    Thank you very much again .
     
  6. Don Hall

    Don Hall Full Access Members

    Age:
    87
    Posts:
    231
    Likes Received:
    49
    Joined:
    Jun 8, 2018
    Location:
    SANTA CRUZ, CA
    Must be employed by NASA.....
     
    Mubarakma likes this.
  7. 762mm

    762mm Full Access Members

    Age:
    39
    Posts:
    325
    Likes Received:
    168
    Joined:
    Aug 28, 2019
    Location:
    Quebec, Canada
    Roger that, Houston.
     
    yockmyer and Mubarakma like this.
  8. 762mm

    762mm Full Access Members

    Age:
    39
    Posts:
    325
    Likes Received:
    168
    Joined:
    Aug 28, 2019
    Location:
    Quebec, Canada
    If the fuse is ok now and some of them still malfunction but the rest work ok, your LED bulbs might have a bad connection (not fully inserted) or they are reverse polarity (need to flip the bulbs around in the plug).

    Failing that, it could be a disconnected (partially or fully) plug in the dome housing. It is possible you accidentally knocked it loose when inserting the new bulbs.

    Some LED bulbs are made super cheap, by the way. It's possible they have failed very prematurely, I had that happen with eBay specials myself. Insert a regular bulb in there and re-test before the next step.

    Finally, if all else fails, it might be a wiring problem, such as a burnt or cut wire under the head liner. Highly unlikely, but possible... especially if you have water infiltration or had work done to the sunroof, etc.
     
    Last edited: Nov 3, 2019
    Mubarakma and Don Hall like this.
  9. Mubarakma

    Mubarakma Full Access Members

    Posts:
    87
    Likes Received:
    16
    Joined:
    Aug 1, 2016
    Location:
    Saudi Arabia
    Thank you very much
    I use below LED
    https://www.amazon.com/gp/product/B01DE7UC6C/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1
    https://www.amazon.com/gp/product/B07FNH8XZK/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

    I don't know it's switch assembly or some wiring issue because I tried same bulb with dome light ON it give a little flash then it's not working even tried rotating the bulb for polarity but no change I thought the bulb gone but I checked same bulb in the driver side and it works so I decide to take complete switch assembly to passenger side then it's works. Now I'm going to replace switch assembly and will see what is next other thing I noticed with working switch sometime same switch will make all dome flash at same time .
     
  10. 762mm

    762mm Full Access Members

    Age:
    39
    Posts:
    325
    Likes Received:
    168
    Joined:
    Aug 28, 2019
    Location:
    Quebec, Canada

    You are doing this properly. Remember : just like solving any logical problem in life, doing mechanical work relies on the process of elimination. Once you eliminate the most likely culprits (bad fuse or bad bulb), you need to work your way backwards to the power source in order to test all components and find what's wrong.

    I would do a continuity test on the wiring myself to make sure it isn't cut or burnt somewhere. If it is, just run new wires. The dome/courtesy lights have two separate circuits: one that is for the lights control by the dimmer switch on the dash, one which is for manual control of each light.

    There's also a accessory timeout relay in the fuse box, which as far as I understand it, will turn off all power to lights, radio, etc. after the engine is off for about 5 minutes.
     
    Mubarakma likes this.

Share This Page