Go Back   Ford Expedition Forum > Ford Expedition Forum > Electrical

Sponsored Ads
Register to remove these ads.


Electrical

Dash Lights Blinking


This is a discussion on Dash Lights Blinking within the Electrical forums, part of the Ford Expedition Forum category!
Hello, I am new to the site and just needed to see if you guys could maybe help with my ...



Reply
 
LinkBack Thread Tools Display Modes
Old 09-17-2012, 11:11 PM   #1 (permalink)
 
LVExpedition's Avatar
Registered User

 
Join Date: Sep 2012
Location: Las Vegas
Posts: 14
Default Dash Lights Blinking

Hello, I am new to the site and just needed to see if you guys could maybe help with my problem. I have a 98 Expedition XLT. Just got it from a dealer down town. Just recently I had to take the dash under the steering wheel to adjust the park lever. Shortly after I started to get a weird blinking (every 2 seconds or so) going on and off on and off. Thought maybe I knocked something loose while I was under there. Checked it out everything was okay. Still continuing, two days ago I thought I would take another look, I noticed that there was a shock sensor underneath the dash and every time I touched it the flashing would occur. I did the logical thing and I just unplugged it. No alarm ever went off and there was no remote for it. It stopped for a day. Now its back again and I don't understand what it could be. All the alarm stuff is disconnected. But I am now noticing it only does it after I shut ignition off and let it sit roughly 2 min... Can someone help me?!?!

Last edited by LVExpedition; 09-17-2012 at 11:41 PM.
LVExpedition is offline   Reply With Quote
Old 10-15-2012, 11:32 AM   #2 (permalink)
Registered User

 
Join Date: Oct 2012
Location: myrtle beach sc
Posts: 2
Default

I am having a similar problem with my 99 xlt. i went to start it this morning and it turned over for a second then stopped. It will not start. With the key out of the ignition and the door open it continuously flashes the interior lights and i hear a clicking noise coming from the fusebox area inside the vehicle.
eightball353 is offline   Reply With Quote
Old 12-13-2012, 12:51 AM   #3 (permalink)
Registered User

 
Join Date: Dec 2012
Location: Cameron park , ca
Posts: 1
Default

Originally Posted by eightball353 View Post
I am having a similar problem with my 99 xlt. i went to start it this morning and it turned over for a second then stopped. It will not start. With the key out of the ignition and the door open it continuously flashes the interior lights and i hear a clicking noise coming from the fusebox area inside the vehicle.
I am having the same problem with the noises. Have you found out what it is ?
hectik is offline   Reply With Quote
Old 12-24-2012, 05:29 PM   #4 (permalink)
Registered User

 
Join Date: Jan 2012
Location: Arizona
Posts: 3
Default

me too. 2000 expedition.

Mine started after a dead battery due to dome light being left on. The key won't turn the starter, but it can be started crossing over at the solenoid. It almost seems like the alarm going off, except I don't have a horn to really know for sure.
lothario is offline   Reply With Quote
Reply

Bookmarks

Tags
alarm, blinking, expedition, ford, shock sensor




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Dodge Ram Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
Scion FR-S Forum
Softball Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum