stamp11127
Last Activity:
May 25, 2017 at 9:51 PM
Joined:
Mar 10, 2012
Posts:
4,253
Likes Received:
443
Trophy Points:
83
Gender:
Male
Birthday:
Sep 8, 1957 (Age: 59)
Location:
Temple, Georgia
Occupation:
Technical College Instructor

Share This Page

stamp11127

Super Moderator, Male, 59, from Temple, Georgia

Staff Member
stamp11127 was last seen:
May 25, 2017 at 9:51 PM
    1. kenneth32
      kenneth32
      I have a 1998 ford expedition that hasn't been driven in 5 years, when it went down numerous things were happening and I wanted answers and possible solutions. I have many issues to discuss and need your advice.
    2. stacey knight
      stacey knight
      Need help! Trying to hotwire fuel pump on my 2001 exped..which one is hot wire? Color?
    3. nycnftm
      nycnftm
      Hello I was the guy with the #22 fuse problem. I see you are in Temple, do you have a shop? I'm in Smyrna. :) I have a GE2524 Meter if that is good enough. Thank you for your reply. After the reply above yours I was about to say, 'Well this was no help"
      My email address is [email protected]
      Andrew
    4. rfm77555
      rfm77555
      Thanks Stamp. Your help is much appreciated. [email protected]
    5. Mstamps1
      Mstamps1
      First initial and last name +1 - lol
    6. robby
      robby
      Hello Stamp my email is [email protected] Thank you very much.
    7. Gigi
      Gigi
      How do I keep my email address private?
    8. Pappy
      Pappy
      [email protected] THANKS!
    9. Jay87LX
      Jay87LX
      Hi Stamp, My email is [email protected] Also is the front diff a limited slip? if so wouldn't it be that much harder to rebuild vs a single gear? Also, Do you think I am right leaning towards the front diff? I was thinking front axles and actually just bought 2 new ones but the more I drive the truck the more I lean to Diff
    10. Jay87LX
      Jay87LX
      Hi, I am having an issue with anoise coming from the front end I can figure out- I was hoping you could give me your thoughts- here is what I wrote in the thread-



      I have a 1999 Expedition 4x4, 145K. The truck is the version that doesn't have 2wd so it always is in awd. Well in the last few months I have been getting a noise, somewhat of a rubbing noise when I am pulling away from a stop and the front wheels are turned. If I pull away straight, I get no noise but as soon as I pull away from a stop and the wheels are turned I get the rubbing or grinding. I am thinking front diff because as the front tires are turned one is traveling a greater distance?


      Thoughts?? I have also since removed the front driveshaft and I still get the noise- it only happens under load though- lets say I am pulling into a perking space and coasting in and turn the wheels I get no noise- but as soon as I go to pull or back out and turn the wheel and am on the gas (underload) I get the noise-
  • Loading...
  • Loading...
  • About

    Gender:
    Male
    Birthday:
    Sep 8, 1957 (Age: 59)
    Location:
    Temple, Georgia
    Occupation:
    Technical College Instructor
    Where Did you hear about us?:
    internet search
    What Year is your Vehicle?:
    1999
    Which Model:
    XLT

    Signature

    99 XLT 4.6 2wd