Help, I don’t want to have to get rid of!

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

jerycle

New Member
Joined
Feb 26, 2024
Posts
1
Reaction score
1
Location
oviedo FL
I have the same issue with 2021 expedition. We live in central FL. Temp is not the issue. We are going to try a higher amp alternator . Our driving is to the store or pick up kids from school. All quick local driving. No highway driving. 150 amp alt can’t charge the battery. Eventually the battery gets to low to start car and create the exact problem you describe.
If bigger alt does not fix it then I trade it for something not Ford. Also try turning off the auto stop start each time you drive . Should not have too but this is a Ford POS we are talking about.
 

LokiWolf

Super Moderator
Staff member
Super Moderator
Joined
Apr 2, 2016
Posts
3,653
Reaction score
2,466
Location
Richmond VA
Again, @caseymalynn I ask, DID YOU RESET THE BMS when you replaced the battery?

@jerycle This is for you to. You have a 2021, and it is 2024, so the battery is ATLEAST 3 years old. The OEM Ford batteries are CRAP! Have you replaced the battery? Short cycles like you are doing are FAR harder on a battery than longer cycles. You might just need a new battery. Don't go cheap, AGM, and the top of the line. I put a DieHard Platinum in our 2020 a few months ago, and many of the weird issues the wife was reporting went away completely. I did do the BMS reset after also. Weird Auto Start/Stop issues, random no start conditions, all gone. The alternator is not your issue, and neither is Start/Stop. If you replace the battery, you must do a BMS reset inorder for it to learn the new batteries capacity.
 

Forum statistics

Threads
53,897
Posts
504,515
Members
47,697
Latest member
langley182
Top