Register to remove these ads

04 problems, hesistating, chugging, slipping, help?

Discussion in 'Transmission & Drive train' started by 04exp, Mar 3, 2012.

  1. 04exp

    04exp New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Mar 3, 2012
    Location:
    high point nc
    I have been experiencing what seems like slipping in my expedition. It's a 5.4, it started a few months after we got it.

    At first it only acted up when you would accelerate hard from a stop, it would seem like it dropped outta gear and then it would catch and go like normal. It did this on and off. I could not recreate it when i took it to aamco so that was a bust.

    One time, and this was the only time, we were headed about 45 mins away and at that point that was the farthest we had drove it. It started to chug violently and a check engine light came on. I was nowhere near a parts store to get it checked out so i went on to where i was going. When I left it was off and it drove fine. tried checking it the next day hoping it would be a pending code but nothing was there.

    coming to the present, it chugs/slips every time we drive it. so what ever it is it's getting worse. I plan on taking it to a transmission shop close by when i get sometime.

    Also it's only done this maybe 3 times but there are instances when it goes into some kinda limp mode and seems like it runs on only 4 cylinders. I turn it off and then back on and it runs like new.

    What makes things so bad is that it wont throw a light so I have know way of knowing where to look, I'm pretty knowledgeable with cars so this has me stumped.

    I've been hearing that it could possibly be a cop? any truth to that?
     
  2. walnuts4x4

    walnuts4x4 Supporting Member Supporting Member

    Age:
    33
    Posts:
    6,471
    Likes Received:
    42
    Joined:
    Jun 18, 2009
    Location:
    Watertown, NY
    expy's are very sensitive to low grade misses... which usually results from COPs going bad but not enough to trip the CEL... also very common is a vacuum leak which can cause problems....
     
  3. 04exp

    04exp New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Mar 3, 2012
    Location:
    high point nc
    But could that make ot seem like a tranny problem? I have 5 years experience working at a part store and my own personal cars so I see a lot of the coils go bad on the 5.4's.
     
  4. WHOISMOOTOO

    WHOISMOOTOO Full Access Members

    Posts:
    1,760
    Likes Received:
    6
    Joined:
    Dec 8, 2009
    Location:
    Dallas, TX
    mine was doing the same thing multiple cylinder miss will send it into limp mode, the cel would flash and sometimes stay on but then go away. easiest fix is changing all the plugs and cops. I changed all my plug and not the cops then they started going on me one at a time but once i changed all 8 it runs strong again. I know what you mean about the trans thing thats what i thought it was at first too.
     
  5. Dib52

    Dib52 Full Access Members

    Posts:
    383
    Likes Received:
    9
    Joined:
    Oct 30, 2011
    Location:
    Wylie, Texas
    Kinda the same thing in my 08. It would momentarily chug/shudder while at speed(@ 70) and I thought tranny. Described the issue to my buddy at the dealership and he said COP. Naturally, I didn't believe him and still was convinced it was a tranny issue because I never got a CEL/code. Took it to the dealership and we hooked up a power balance laptop and watched the graphs while driving around. I got the obligatory, I TOLD YOU SO from my buddy, #2 and #5 were missing. Two new coils and I'm all fixed up.
     
  6. genehull123

    genehull123 New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Apr 1, 2015
    Location:
    pa
    2008 expy 5.4

    i have a similar issue but mine is when I stop or back up a hill then stop it chugs and rattles like a diesel and I pop it in neutral and it revs up fine again puzzled is this torque converter or loss of fuel,spark,5.4 no lights on ,130k rund fin on highway
     
  7. shani

    shani Member

    Posts:
    12
    Likes Received:
    0
    Joined:
    Mar 30, 2015
    Location:
    Saudi Arabia
    Dib52

    Hi

    My car is exactly the same of you. only difference is it is King Ranch.
    I experience shudder while driving between 35 to 50 miles. I already posted a thread in this forum with the name "Ford expedition 2008 King Ranch shudder problem". please go through my thread and advise me. Thanks.
     
  8. shani

    shani Member

    Posts:
    12
    Likes Received:
    0
    Joined:
    Mar 30, 2015
    Location:
    Saudi Arabia
  9. genehull123

    genehull123 New Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Apr 1, 2015
    Location:
    pa
    08 expy chugging and rattling at stop

    hi,havent narrowed it down yet Im thinking starting with plugs and cops and
    process of elimination since I have no cel may throw a computer analyzer at it .
     

Share This Page