Register to remove these ads

service engine soon light came on...

Discussion in '1st Gen - 1997 - 2002' started by AaronLG, Jul 12, 2011.

  1. AaronLG

    AaronLG Full Access Members

    Posts:
    436
    Likes Received:
    3
    Joined:
    Jan 16, 2010
    Location:
    Lubbock
    what would cause this? how do I diagnose the issue? can they check the code or is it something different since it's not the check engine light? I think it came on about the time I did my exhaust but it went a way for a while.
     
  2. Canadian Expy

    Canadian Expy Full Access Members

    Posts:
    3,039
    Likes Received:
    139
    Joined:
    Jul 16, 2010
    Location:
    Toronto ON
    yeah you should be able to scan for codes, what did you do to the exhaust?? Did it cause O2 sensor to throw a code?
     
  3. Explor2Exped

    Explor2Exped Full Access Members

    Age:
    30
    Posts:
    701
    Likes Received:
    1
    Joined:
    Mar 29, 2011
    Location:
    Nashville, TN
    Did you check for codes?
     
  4. AaronLG

    AaronLG Full Access Members

    Posts:
    436
    Likes Received:
    3
    Joined:
    Jan 16, 2010
    Location:
    Lubbock
    Haven't checked for codes, that's another issue, fuse for port keeps popping. had the rear cat removed, didn't think there is a O2 on it. maybe that's the issue.
     
  5. Canadian Expy

    Canadian Expy Full Access Members

    Posts:
    3,039
    Likes Received:
    139
    Joined:
    Jul 16, 2010
    Location:
    Toronto ON
    If you removed the rear cat that can throw codes. did you put a new front cat on? you can get away with a single cat if the new front cat can handle all the extra pollution. Also there is a rear O2 that if put in the wrong place, distance from the cat it can also throw codes. How do you like the rear cat delete?? I want to do that badly:drool2: but not sure what new cat to get? so I don't throw codes. Magnaflow makes some but unsure which model to get???:shrug:
     
  6. AaronLG

    AaronLG Full Access Members

    Posts:
    436
    Likes Received:
    3
    Joined:
    Jan 16, 2010
    Location:
    Lubbock
    Gave it more sound for sure. Haven't noticed much of anything else. Would a programer be able to clear it?
     
  7. KWT2000

    KWT2000 Full Access Members

    Posts:
    2,376
    Likes Received:
    33
    Joined:
    Feb 4, 2010
    Location:
    NINE MILE FALLS
    make sure the rear 02 sensors are plugged in... i am still running the stock front cats with the rears gone and no problems...

    but also your front cats could be bad...

    with that fuse popping it could be a different porblem all together
     
  8. Canadian Expy

    Canadian Expy Full Access Members

    Posts:
    3,039
    Likes Received:
    139
    Joined:
    Jul 16, 2010
    Location:
    Toronto ON
    I know my Edge reads and clears codes
     
  9. walnuts4x4

    walnuts4x4 Supporting Member Supporting Member

    Age:
    33
    Posts:
    6,471
    Likes Received:
    42
    Joined:
    Jun 18, 2009
    Location:
    Watertown, NY
    +1 for edge clearing codes.... and no problems for rear cat delete....
     
  10. Tigster

    Tigster Full Access Members

    Posts:
    220
    Likes Received:
    1
    Joined:
    Oct 30, 2010
    Location:
    Florida
    any auto parts store will pull the codes for free so you can see what it is first.
     

Share This Page