Headed into the Dealer for Work

Discussion in '4th Gen - 2018 - present' started by aggiegrad05, Apr 20, 2018.

  1. aggiegrad05

    aggiegrad05 Full Access Members

    Age:
    34
    Posts:
    206
    Likes Received:
    112
    Joined:
    Nov 6, 2017
    Location:
    North Texas
    Although my service loaner is a Lead Foot Grey (best color Ford makes) ‘18 F150 XLT SCrew FX4 Sport with the max tow and the big ecoboost...so I get to drive that thing like I stole it for a while. Haha. That puppy MOVES.
     
  2. edizzle

    edizzle Full Access Members

    Age:
    40
    Posts:
    477
    Likes Received:
    212
    Joined:
    Dec 25, 2017
    Location:
    Cashiers
    I didn’t know they made the f150 in lead foot. I love that color on the GT350 mustang.
     
    sprayfoam620 likes this.
  3. aggiegrad05

    aggiegrad05 Full Access Members

    Age:
    34
    Posts:
    206
    Likes Received:
    112
    Joined:
    Nov 6, 2017
    Location:
    North Texas
    Yep[​IMG][​IMG]
     
    edizzle and JExpedition07 like this.
  4. cmiles97

    cmiles97 Well-Known Member

    Age:
    50
    Posts:
    47
    Likes Received:
    24
    Joined:
    Apr 5, 2018
    Location:
    Mobile, Al
  5. aggiegrad05

    aggiegrad05 Full Access Members

    Age:
    34
    Posts:
    206
    Likes Received:
    112
    Joined:
    Nov 6, 2017
    Location:
    North Texas
    Not bad news at all! I am reassured to know it's a somewhat known issue and mine is not uniquely defective. Many of the videos users posted are EXACTLY the same noise I am having. Thanks for the info, I truly appreciate it!!!
     
  6. aggiegrad05

    aggiegrad05 Full Access Members

    Age:
    34
    Posts:
    206
    Likes Received:
    112
    Joined:
    Nov 6, 2017
    Location:
    North Texas
    And this is what they did last time...I am not an engineer so I am not 100% sure what they replaced, but maybe they did the fix that people were recommending on that other forum.

    upload_2018-5-16_11-6-58.png
     
  7. aggiegrad05

    aggiegrad05 Full Access Members

    Age:
    34
    Posts:
    206
    Likes Received:
    112
    Joined:
    Nov 6, 2017
    Location:
    North Texas
    Well I picked it up from the dealer today. Apparently there are TWO valves in the system (a check valve and something else). They had replaced one of them the first time and now they have replaced the other.

    Or something. I didn’t get any paperwork (which was a little squirrelly) but they promise it’s fixed. And I know where to find them if it’s not. Haha
     
    edizzle likes this.

Share This Page