Traction Control Issue / but unique.

Discussion in '2nd Gen - 2003 - 2006' started by 04ExpeditionEB, Dec 15, 2014.

  1. 04ExpeditionEB

    04ExpeditionEB Active Member

    Age:
    47
    Posts:
    27
    Likes Received:
    1
    Joined:
    Nov 26, 2014
    Location:
    Bristol PA
    Ok so last I posted, i had Advtrak and ABS on my dash, had codes pulled, was told C2777 and C2778. All the sensors appeared to be functional and passed test. I was then told I had no option but to get the ABS module reprogrammed at the dealer (as its dealer option only) to clear this. well a week later (still didnt get re-programmed) the AS indication stays off, Advtrac does not show warning but the traction control indication is constantly blinking all the time. If I turn off advtrac while in park it stays off until I hit about 20-25MPH. then I get advtrac off/ check advtrac. the center consoled swith still works as normal, if I push it It illuminates (OFF) I push it again and the light goes out but there is nothing on my command center to show its disabled. I run the test and it shows (check advtrac) until I turn off the truck and restart it.

    So I'm stumped as to what could the root cause be?

    Can the brake shoes be the root cause I know they are low (and tons of brake dust) be causing an issue?
    Whrere to start as I cant get a code to pull

    No googeling has assisted in finding a cause or answer.
     
  2. 04ExpeditionEB

    04ExpeditionEB Active Member

    Age:
    47
    Posts:
    27
    Likes Received:
    1
    Joined:
    Nov 26, 2014
    Location:
    Bristol PA
    Bumping..seems to have been lost in the shuffle.
     
  3. nikola.kz

    nikola.kz New Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Feb 6, 2014
    Location:
    Kazakhstan, Almaty
    hi where was problem in your story? have the same codes cant find answer
     

Share This Page