APIM shows no version or build number

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Frznfngrs

New Member
Joined
Oct 23, 2016
Posts
3
Reaction score
0
Location
Newcastle, OK
Hello all, long time, since 06 Expedition owner, just bought a 2021 Plat Max for my wife. Felt bad having her driving my 03 now that it has 295k+ miles on it and wanted to treat her to something nicer.

This 2021 only has 47k on it, so to me its a brand new vehicle. However I am having some issues with the APIM it seems.

I have no version numbers, which appears to be a problem with trying to apply an update. I cannot use any wireless feature, or ford pass connect. It is equipped with a modem, and when I first picked it up I even saw the cell connection bars in the top right of the screen. But they disappeared one day randomly, AFTER, mind you, I subscribed to get the att hotspot. But when I went to use it for the first time that's when I discovered all these issues. So I have tried updating the sync3, via both the ford method and the cyanlabs method. Those familiar with the cyanlabs tool may be wondering what I chose for my current version, well that I determined was it is 3.4.21020 base on what ford had in their system.

So to be clear,
Wireless just scans, never leaves the scanning please wait screen
Hotspot, basically same behavior
Ford pass connect, same behavior
Unit has locked up once while driving
Multiple master resets performed no change
Disconnected battery for 20 mins, no change
more master resets.
Attempted updating via usb, several, 5+ different usb sticks using different methods, exfat partitioning, Fat32 partitioning, always MBR.
USB seems to never be detected if the stick has an update on it. If i put the same stick with nothing on it, it is detected and indexed by the unit.
Attempting a ford connect reset results in a "reset failed" message


I am at a loss. For the money I really dont feel like a simple computer should be losing its version/build number out of the blue.

Anyone run into or seen anything like this? Haven't found a super relevant post yet.

Id love to update to try to resolve the issue but I have a gut feeling the update isnt reading or kicking off from USB due to the current version being completely unknown.
 

Fizzy

Full Access Members
Joined
Dec 18, 2020
Posts
175
Reaction score
127
Location
Alberta, Canada
Before, they are what prompted me to even attempt it.

Flashing something that is not working properly is a sure-fire path to permanently bricking it. You need to get it working the way it is before you do anything as potentially destructive as flashing the firmware.

What happens when you scan the truck with Forscan? Does the APIM respond and send its config back?
 

LokiWolf

Super Moderator
Staff member
Super Moderator
Joined
Apr 2, 2016
Posts
3,653
Reaction score
2,466
Location
Richmond VA
Stop messing with it, if it is under any type of warranty, take it to the dealer. It needs a new APIM.
 
OP
OP
F

Frznfngrs

New Member
Joined
Oct 23, 2016
Posts
3
Reaction score
0
Location
Newcastle, OK
Thanks for the information everyone. Hate to hear that though. Going out of town this weekend and was hoping for a quick fix for the trip. Appreciate the replies.
 

Forum statistics

Threads
53,897
Posts
504,515
Members
47,697
Latest member
langley182
Top