2019 4*4 Stealth shifting weirdness

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Left Coast Geek

Full Access Members
Joined
Aug 31, 2023
Posts
251
Reaction score
90
Location
Mid Left Coast
I'm on an extended road trip in Mexico, towing a 4500 lb small fiberglass camp trailer. A bunch of times, when the truck is in tow/haul mode, and I give it some gas to pass someone basically nothing happens. It doesn't rev. Doesn't rev. It doesn't shift it. Just kind of putters along and then there's a delayed clunk shift and then it finally has some power. If I remember I've gotten to putting it in sport before I do a pass then it responds the way I expect.

Is this likely the firmware problem with delayed shifting and stuff in 4/5? I don't know what gear I'm in, because the 10 speed gear display went out the second week of this trip. I won't be home until early May, so I'm not going to try to bring it to a Ford shop here in Mexico because we have just too little time and are doing too much. We're never more than 4 days in the same city., and mostly we're staying in relatively rural areas. Fantastic caravan guided RV tour, the organized tours have been far more fun than I even expected them to be. Highlight next month will be the total solar eclipse in the Mazatlan area

Oh, this Expedition has the HD tow package, it was bundled with Stealth in 2019. By the way, I'm really glad I put 18 in wheels on this truck instead of the 22s it came with. Mexican highways and back roads are gnarly, the topes (speed bumps ) are vicious, and so are the potholes.

PXL_20240306_140747210-X2.jpg
 
Last edited:

SyndicateZ

Full Access Members
Joined
Nov 11, 2022
Posts
666
Reaction score
445
Location
Mass
Mayne your tranny just needs to be "reset"

also

When my gear #'s displayed disappeard after a PCM flash i had to....

While the gear selector in in Drive "D" , push the "+" button located next to the gear rotary selector to show the gear #'s display back on your cluster.
 

Hellwig

Full Access Members
Joined
Apr 6, 2022
Posts
421
Reaction score
209
Location
Virginia
I'm on an extended road trip in Mexico, towing a 4500 lb small fiberglass camp trailer. A bunch of times, when the truck is in tow/haul mode, and I give it some gas to pass someone basically nothing happens. It doesn't rev. Doesn't rev. It doesn't shift it. Just kind of putters along and then there's a delayed clunk shift and then it finally has some power. If I remember I've gotten to putting it in sport before I do a pass then it responds the way I expect.

Is this likely the firmware problem with delayed shifting and stuff in 4/5? I don't know what gear I'm in, because the 10 speed gear display went out the second week of this trip. I won't be home until early May, so I'm not going to try to bring it to a Ford shop here in Mexico because we have just too little time and are doing too much. We're never more than 4 days in the same city., and mostly we're staying in relatively rural areas. Fantastic caravan guided RV tour, the organized tours have been far more fun than I even expected them to be. Highlight next month will be the total solar eclipse in the Mazatlan area

Oh, this Expedition has the HD tow package, it was bundled with Stealth in 2019. By the way, I'm really glad I put 18 in wheels on this truck instead of the 22s it came with. Mexican highways and back roads are gnarly, the topes (speed bumps ) are vicious, and so are the potholes.

notorious CDF drum issue, considering the model year of your vehicle. If parts are available, that job probably takes a couple of days in dealership.
 
OP
OP
Left Coast Geek

Left Coast Geek

Full Access Members
Joined
Aug 31, 2023
Posts
251
Reaction score
90
Location
Mid Left Coast
Mayne your tranny just needs to be "reset"

also

When my gear #'s displayed disappeard after a PCM flash i had to....

While the gear selector in in Drive "D" , push the "+" button located next to the gear rotary selector to show the gear #'s display back on your cluster.
Doy, I feel like an idjot now. Yup, that's it. I've had the Expy since November and have driven it about 8000 miles and am still learning new stuff. Also, in D, the minus button let's you lock out 10, or 9,10, or 8,9,10...
 

HVYMETL

New Member
Joined
Mar 24, 2024
Posts
2
Reaction score
0
Location
Utah
I recently bought a 2020 Max 303A Stealth Limited, took it on a short, 1600 mile road trip from Northern Utah to Arizona, through Vegas then back to Utah, and my transmission had the exact same symptoms...occasional no shift on passing attempt, loud clunk, apparent momentary loss of power to drivetrain, and gear indicator display disappeared. However, add in hard shifts in and out of 8th gear and a momentary code alert that flashed on my screen that disappeared so quickly I could not make it out. I made sure to not do anything that required disconnecting the battery and took it to Ford asap so they could pull any codes. Sure enough, codes showed an issue related to a TSB that was out, and they ended up replacing the main valve assembly in the tranny. Fortunately I still have powertrain warranty in effect, so didn't have to pay for any of it. Took 2 days of shop time, now it's back on the road and performing the way Ford designed it to.

1714232517291.png
 
Top