2015 Ford Expedition clogged fresh air intake

Discussion in 'Heating & Cooling' started by Iamsam1117, Apr 19, 2019.

  1. Iamsam1117

    Iamsam1117 Well-Known Member

    Age:
    30
    Posts:
    46
    Likes Received:
    3
    Joined:
    Dec 16, 2018
    Location:
    California
    Good morning gents, I'm getting a whistling/clogged sound when running in non recirculation mode. In previous cars it was an easy fix. However I've noticed the 2015 doesn't have a cabin filter and cannot locate the outside air intake. Any help finding the path to remove the clog?
     
  2. Sgt Darkness

    Sgt Darkness Full Access Members

    Posts:
    231
    Likes Received:
    51
    Joined:
    Oct 24, 2018
    Location:
    East Tennessee
    Where is the clogged sound coming from? I assume it’s coming from one of your a/c vents but not a good idea to assume anything. Can you record the sound it’s making on your cell? Did it just start or has it been going on for awhile?
     
  3. Iamsam1117

    Iamsam1117 Well-Known Member

    Age:
    30
    Posts:
    46
    Likes Received:
    3
    Joined:
    Dec 16, 2018
    Location:
    California
    So basically it makes it on full air. Like a whistling noise. Being an a/c tech it sounds like what would be a clogged filter. However if you push the return air button it disappears. Could also be a busted fresh air damper I suppose too. I only have the electrical manual for the car.
     
  4. MrSticker

    MrSticker Full Access Members

    Posts:
    1,157
    Likes Received:
    430
    Joined:
    May 4, 2016
    Location:
    Penfield, New York
    If all else fails would you consider a big shop vac sucking on an offending vent and then reversing and blowing? Might disrupt the issue. Just a pathetic workaround I guess. I refer to my big shop vac as the suck and blow machine. Lol
     
    Sgt Darkness likes this.
  5. 99WhiteC5Coupe

    99WhiteC5Coupe Full Access Members

    Posts:
    592
    Likes Received:
    187
    Joined:
    Jun 3, 2015
    Location:
    USA

    I bought a new 2015 Expedition Limited 4x4. During one service visit, the Ford dealer said there was a computer update for the HVAC controller, and it was performed.

    After the update - when I use the a/c on high, including the rear a/c on any speed, I now get a whistling sound from the system. If I switch to recirculation mode, the sound goes away. If I get the whistling sound, it will also go away if I slightly open the rear, tilt-out windows.

    I was irritated the dealer performed an update, which only caused a problem. On return visits, the advisor said they could not “undo” the update - and there were no additional updates.

    I removed the LR taillight assembly to ensure the vent flap fitting was not clogged, and it wasn’t.

    I’m stumped.
     
  6. Hamfisted

    Hamfisted Full Access Members

    Posts:
    574
    Likes Received:
    148
    Joined:
    Nov 20, 2012
    Location:
    Ft Lauderdale
    It's your truck trying to tell you to just run it in recirc mode, and not be constantly trying to cool down hot outside air.
     

Share This Page